Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
APPLE DVD STUDIO:HomeDVD Studio ForumDVD Studio TutorialsFinal Cut Studio

DVD Studio scripts fail in DVD player

COW Forums : Apple DVD Studio Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook
Paddy UglowDVD Studio scripts fail in DVD player
by on Feb 4, 2010 at 3:20:32 pm

I've been writing a scripted (instead of Storyed) Play All disc, which works perfectly in the Preview but utterly fails in OS X DVD Player and VLC Player (and presumably every other player too). I'm pretty annoyed with DVD Studio (again).
My disc does this:
1. The root Menu buttons open a buttonless menu slide which times out to "play-movie" script.
2. "play-movie" uses SPRM8 to work out what the last button was, does a bit of maths to make button1 do an indirect jump to track 1, 2 to 2, etc.
3. At the end, the track jumps to the "return?" script which checks a flag to see if a play all button's been pressed. If not, it jumps to another buttonless menu slide.
4. The menu slide times out to the "return-button-select" which uses SPRM4 to work out what the last track played was, does some maths with that and jumps to the right button on the root menu.

Like I said, works perfectly on the DVD Studio preview, but not on a software DVD player (all buttons play track 1).
Any ideas?
Thanks
- Paddy


Return to posts index
Reply   Like  

Paddy UglowRe: DVD Studio scripts fail in DVD player
by on Feb 4, 2010 at 3:52:30 pm

Some progress...
I've tried making one main menu button go straight to my "play-movie" script, instead of to the "slide" menu. THAT appears to work, so I'm guessing that the software DVD player is forgetting/resetting the SPRM8 value when it shows the menu?
Maybe I need to use a track for my "before" and "after" slides instead?
Any more thoughts/experience?
Thanks
- Paddy


Return to posts index
Reply   Like  

eric pautschRe: DVD Studio scripts fail in DVD player
by on Feb 4, 2010 at 4:00:52 pm

Without seeing your script how could we help? :)



Return to posts index
Reply   Like  


Paddy UglowRe: DVD Studio scripts fail in DVD player
by on Feb 4, 2010 at 4:30:14 pm

Thanks for you reply.
Actually, I think I've worked it out myself.
I've altered my disc so that GPRM0 is set to last-button-pressed BEFORE the blank menu, then another script afterwards to jump to the track I want.
I suspect that opening even a blank buttonless menu will reset the SPRM8 last-button-pressed value, which meant my script which relied on the SPRM8 from the *first* menu wouldn't work.
(I'm using a menu for my before/after sldes to make it easy to edit them by using DVD studio text and/or .PSDs).
Cheers all
- Paddy


Return to posts index
Reply   Like  

eric pautschRe: DVD Studio scripts fail in DVD player
by on Feb 4, 2010 at 5:03:08 pm

Yes that will reset that SPRM 8. Did you have the default button setting In the off position?



Return to posts index
Reply   Like  

Paddy UglowRe: DVD Studio scripts fail in DVD player
by on Feb 4, 2010 at 5:45:45 pm

Yes, default button was "not set" because there ARE no buttons! But I kind of forgot they were menus so didn't expect them to act like them. My mistake!
And likewise, I had to use the "gprm based button" setting when i jumped back to the root menu...
So my lesson is not to rely too much on the System registers in real DVD players - Simulator seems to have a better memory for them.
I'm glad of the ability to write DVD disk images though, or I would have gone through a box or two (or 3) of discs by now!
- Paddy


Return to posts index
Reply   Like  


eric pautschRe: DVD Studio scripts fail in DVD player
by on Feb 4, 2010 at 5:52:34 pm

Actually it's the other way around. The simulator is very buggy and should never be used as an absolute. It's just there as a basic guide.



Return to posts index
Reply   Like  

Paddy UglowSPRM 4 problem
by on Feb 5, 2010 at 11:30:38 am

Phew... FINALLY got it working properly in DVD player.
Each track jumped to my "return?" script which checked SPRM4 to get the number of the last track played, which worked in the simulator, but not in "real life". So I set a GPRM track counter instead and that works.
Isn't SPRM 4 meant to be thhe last track played number, or am I making a mistake? The track jumps straight to the script, so I'd have thought using SPRM 4 should have worked...
Well, my "time saving" template has used up a couple of days, but should come into its own next time someone wants a play-all: no more messing around in FC pro making showreels, and making all those Stories in DVD Studio.
- Paddy



Return to posts index
Reply   Like  

eric pautschRe: SPRM 4 problem
by on Feb 5, 2010 at 3:52:30 pm

DVDSP is abstraction layer tool so there could be issue with tracking that SPRM. Just so you know, stories is much cleaner way to do a play all. You could have yourself alot of hassle.
Meanwhile, Ill check that sprm 4 and post my findings



Return to posts index
Reply   Like  

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook


FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]