Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
APPLE FINAL CUT PRO:HomeFCP ForumFCP XFCPX TechniquesFCP TutorialsFC ServerBasics ForumPodcastFAQ

Re: Stupid questions regarding CUDA, OpenCL and Premiere 6

COW Forums : Apple FCPX or Not: The Debate

VIEW ALL   •   ADD A NEW POST   •   PRINT
Share on Facebook
Respond to this post   •   Return to posts index   •   Read entire thread


Andrew RichardsRe: Stupid questions regarding CUDA, OpenCL and Premiere 6
by on May 8, 2012 at 5:13:40 pm

[Aindreas Gallagher] "Dennis from Adobe completely hypothetically suggested that it was reasonably-ish doable to point the adobe Open CL implementation to a card not specifically listed by adobe as compatible, does anyone have a view to that? "

I have a 2010 iMac 2.93GHz i7 Quad + HT, 16GB RAM, with a Radeon 5750 1GB.

I just downloaded the PPro CS6 Trial, edited the /Applications/Adobe Premiere Pro CS6/Adobe Premiere Pro CS6.app/Contents/opencl_supported_cards.txt file, and fired her up. Mercury GPU acceleration was enabled, so I pulled up some 720p60 footage from my T2i, laid it into the timeline, set it to loop, and then starting messing with the motion controls during playback.

No stutters, so hiccups. I added 3-way CC. No stutters, no hiccups. Let's break it. Added Warp Stabilizer. It kept playing, though at much lower fidelity as it analyzed in the background. Mind you it is still looping playback in the timeline.

I quit, removed the edit from the txt file, and relaunched. Warning: no MPE GPU! Now it can't do any of the above gymnastics.

Then I modded the txt file again, fired up, and tried a few streams of T2i 1080p29.97 layered. Looped playback, started playing with motion parameters. Added 3-way CC to each clip, made some random changes. Still looping playback, and just a slight stutter for a beat following a couple of my inputs, but that could be that these are playing back from a single SATA drive.

So I got solid MPE GPU action with my older OpenCL card, and the newer ones will probably do more than mine does. But you will have to edit your opencl_supported_cards.txt file.

Best,
Andy


Posts IndexRead Thread
Reply   Like  
+2
Share on Facebook


Current Message Thread:




LOGIN TO REPLY



FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]